Go Back  British Expats > Living & Moving Abroad > Australia > The Barbie
Reload this Page >

Panasonic TZ20 camera, flash not working, anyone got one of these?

Panasonic TZ20 camera, flash not working, anyone got one of these?

Reply

Old Dec 8th 2018, 12:59 am
  #1  
BE Enthusiast
Thread Starter
 
Joined: Jun 2012
Location: NSW, Australia
Posts: 332
Lucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really nice
Default Panasonic TZ20 camera, flash not working, anyone got one of these?

I bought this camera via Gumtree a week ago. I was thoroughly pleased until I tried using the flash today. The camera indicates all ok, but the flash doesn't fire. I'm using it in 'P' mode with flash forced on. The flash icon on the screen indicates 'ok'. After taking the picture the screen data shows the flash icon so it *thinks* it flashed, but it doesn't.

Seller reckons the camera was fully tested & working before selling. I smell something stinky. I've been sold a pup. I've told the seller I want a refund ... obviously no reply, which makes me think even more I've been conned.

But, just in case, anyone else got one of these cameras, or a higher/lower model? This to me is an upgrade from a 10yo TZ7, so I'm pretty sure I'm using the TZ20 correctly. You don't know what you don't know though...

Any hints/tips, both on the camera, and getting Gumtree/Paypal to force a refund, all gratefully received!

Cheers
Lucas_Dad is offline  
Reply With Quote
Old Dec 8th 2018, 6:15 am
  #2  
snɐןɔ ʎʇıuɐs
 
GarryP's Avatar
 
Joined: Nov 2006
Posts: 6,421
GarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond reputeGarryP has a reputation beyond repute
Default Re: Panasonic TZ20 camera, flash not working, anyone got one of these?

I have a similar, old, version of this camera.

You can get at the flash part of the camera, basically by taking the whole thing apart. There is a battery(?) and electronics board, which is about $15 to buy as spares.

https://www.ifixit.com/Guide/Panason...placement/3808
GarryP is offline  
Reply With Quote
Old Dec 10th 2018, 12:59 am
  #3  
BE Enthusiast
Thread Starter
 
Joined: Jun 2012
Location: NSW, Australia
Posts: 332
Lucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really niceLucas_Dad is just really nice
Default Re: Panasonic TZ20 camera, flash not working, anyone got one of these?

Thanks Garry, that site is useful. I used to work in IT so I'm pretty good at diagnosing problems, but I have no experience taking cameras apart, so I am a bit hesitant in case I replace the flash unit, and that turns out not to be the problem. Probably worth a go though as the camera was otherwise a good deal at $100. Shame the entire camera has to be taken apart completely to get to the flash.

Cheers
Lucas_Dad is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service